Folgendes fehlt auf ‚Server-Name‘

Problem

Folgendes fehlt auf ‚<Server-Name>‘

Details

Auf einem oder mehreren Servern werden beim Update der DB mit dem Assistenten (Config Wizard) fehlende Patche angezeigt.

Die Meldung lautet:
Folgendes fehlt auf ‚<Server-Name>‘
Wobei <Server-Name> der Server ist, auf dem angeblich die Software-Komponente fehlt.

Man ist sich aber sicher, dass die Patche auf allen Servern der SharePoint Farm installiert sind.

Folgender Zeile bestätigt die angeblich fehlende Komponente:

# Zeigt SP-Server, auf welchen die Installation einer Softwarekomponente / eines Patches / eines Updates im Vergleich zu anderen Farmservern fehlt
(Get-SPProduct).Servers | ? { $_.InstallStatus -eq "InstallRequired" } | % { $_.RequiredButMissingPatches } | ft PatchName, Version, ServersMissingThis, Link, PatchGuid -AutoSize

<# Beispielausgabe:

PatchName                                                                                  Version        ServersMissingThis Link              
---------                                                                                  -------        ------------------ ----              
Update for Microsoft SharePoint Enterprise Server 2013 (KB3039703) 64-Bit Edition          15.0.4719.1002 {my-sp-server01}     http://support.mic...
Update for Microsoft Project Server 2013 (KB3054804) 64-Bit Edition                        15.0.4719.1002 {my-sp-server01}     http://support.mic...
Security Update for Microsoft SharePoint Enterprise Server 2013 (KB3023055) 64-Bit Edition 15.0.4719.1002 {my-sp-server01}     http://support.mic...
Security Update for Microsoft SharePoint Enterprise Server 2013 (KB3039725) 64-Bit Edition 15.0.4719.1002 {my-sp-server01}     http://support.mic...
Security Update for Microsoft SharePoint Enterprise Server 2013 (KB3039736) 64-Bit Edition 15.0.4719.1002 {my-sp-server01}     http://support.mic...
Security Update for Microsoft SharePoint Foundation 2013 (KB3054792) 64-Bit Edition        15.0.4719.1002 {my-sp-server01}     http://support.mic...
Update for Microsoft SharePoint Enterprise Server 2013 (KB3039703) 64-Bit Edition          15.0.4719.1002 {my-sp-server01}     http://support.mic...
Update for Microsoft SharePoint Enterprise Server 2013 (KB3039703) 64-Bit Edition          15.0.4719.1002 {my-sp-server01}     http://support.mic...
Security Update for Microsoft SharePoint Enterprise Server 2013 (KB3023055) 64-Bit Edition 15.0.4719.1002 {my-sp-server01}     http://support.mic...
Security Update for Microsoft SharePoint Enterprise Server 2013 (KB3023055) 64-Bit Edition 15.0.4719.1002 {my-sp-server01}     http://support.mic...
. . .


#>

Fix

Die lokalen Patche mit der DB abgleichen

Wenn man sicher ist, dass man die Patche installiert hat, kann man folgendes versuchen. In der SharePoint-PowerShell auf allen Servern, die in der Ausgabe (s.o.) aufgelistet sind, folgende Zeile ausführen:

# Die lokal installierten Patche mit der Config-DB abgleichen
Get-SPProduct -Local

Damit werden die lokal installierten Patche mit der Konfigurationsdatenbank abgeglichen und berichtigt!

Links

  1. http://thesharepointfarm.com: The Magic of Get-SPProduct -Local
Teile diesen Beitrag

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.